ABOUT THE TOPIC


 

This section describes about VSP upgrade processes from previous releases (VSP 2.1.0 onwards) to VSP 2.6 The Processes include:

  1. VSP Upgrade of Kubernetes using kubectl  - VSP upgrade processes of Kubernetes using kubectl from previous releases (VSP 2.1.0 onwards) to VSP 2.6

  2. VSP Upgrade of Kubernetes using HelmChart - VSP upgrade processes of containers using Helm Charts

  3. VSP Upgrade of VM - VSP upgrade processes for Virtual Machine from previous releases

 

CMS - PROBE COMPATIBILITY


The table below represents the compatibility of CMS and Probe across VSP releases: 

 

CMS Version Probe Version Compatible or Not Value Considered

VSP 2.5 and higher

VSP 2.5 and higher

Compatible

App Collective ID

VSP 2.5 and higher

VSP 2.4 and lower

  • VSP-Web for Ruby on Rails is not backward compatible. The application is NOT PROTECTED. In such cases, ensure that VSP Probe is also upgraded to version 2.5

  • If the Probes are of version 2.4.x and below, ensure that only option 0 is used for Kafka. Do not use options 1 or 2. as they are not supported

App Collective ID

(App Context Path value is ignored)

VSP 2.4 and lower

VSP 2.5 and higher

Compatible

App Collective ID

(App Context Path value is ignored)